Do not adjust your sets….

| April 25, 2008

I was startled a few days ago to see this blog show up in Google as being potentially harmful (e.g., “this site may harm your computer”). As it turns out, we’d been the victims of an exploit in WordPress (my fault for not having upgraded to WP 2.5 sooner).

As a result, we backed up the posts, etc., in XML form and then completely deleted the WordPress installation. After that, we did a clean install of WordPress 2.5, added the 2.51 security upgrades, and restored the posts, etc.

There have been a few problems with the restorations (particularly with linked images, the sidebars and the blogroll); bear with us. ..bruce w..

UPDATE: Oh, and I changed the WordPress theme.

UPDATED UPDATE: By popular demand, I changed the WordPress theme back. 🙂

Be Sociable, Share!

Category: Admin, Main

About the Author ()

Webster is Principal and Founder at Bruce F. Webster & Associates, as well as an Adjunct Professor of Computer Science at Brigham Young University. He works with organizations to help them with troubled or failed information technology (IT) projects. He has also worked in several dozen legal cases as a consultant and as a testifying expert, both in the United States and Japan. He can be reached at bwebster@bfwa.com, or you can follow him on Twitter as @bfwebster.

Comments are closed.